Skip to Content

Frealix seems to have trouble splitting the ali file, no error message

1 reply [Last post]
LRad
Offline
Joined: 23 Aug 2017

Hi!

I'm learning how to use frealix for 3D reconstructions. I'm using 3 micrographs of synthetic amyloid fibrils. I selected 14 filaments (5 points per filament). When I run this command:

./flx_wrap.rb -r 1 -f 20 -s 20 -t 20 -n 1 --threads 2 -a waypoints.ali parameter_startup.flx

then a new folder for round 00 is created, the waypoints file is copied into it, and in the terminal it says:

I, [2017-08-23 12:44:01 #6814] INFO -- flx_wrap: Thanks for using Frealix! Let's get to work...
I, [2017-08-23 12:44:01 #6814] INFO -- : We will be starting on round 0 and doing 1 refinement rounds using parameters from parameter_startup.flx
I, [2017-08-23 12:44:01 #6814] INFO -- parallelRun: Round 0: Processing with 1 nodes, each with 2 threads
I, [2017-08-23 12:44:01 #6814] INFO -- parallelRun: Round 0: Splitting the input alignments file into 1

And then nothing else happens. Htop shows that ruby ./flx_wrap.rb etc is active and using 100 % CPU.

When I kill it, it says:

/usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:377:in `update_job_status': Interrupt
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:367:in `block in update_all_jobs_status'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:366:in `upto'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:366:in `update_all_jobs_status'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:232:in `assign_host_to_job'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:319:in `block in run'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:309:in `upto'
from /usr/local/frealix-1.1.0-linux64/FrealixRunner.rb:309:in `run'
from /usr/local/frealix-1.1.0-linux64/FilamentRefineParallel.rb:204:in `splitAli'
from /usr/local/frealix-1.1.0-linux64/FilamentRefineParallel.rb:49:in `parallelRun'
from ./flx_wrap.rb:303:in `'

I have all the required files in my folder:

waypoints file
ctffind files
parameter_startup.flx
parameter_refine.flx
the micrographs (as a stack)
link to frealix
flx_wrap.rb

I installed Frealix 1.1.0. I can call the menu and help from the command line, but I have not really used it for anything yet. The waypoints I selected and exported with Tigris display. I checked the Frealix forum but didn't find anything that could solve my problem there.

So I am puzzled as no error message is shown, but there is obviously nothing happening, even after letting it run for over half an hour.

I would be grateful for your reply.

LRad
Offline
Joined: 23 Aug 2017
Deactivating the memory check solved it

I followed Alexis' suggestion in an email to a colleague and changed line 13 in rubylix.rb from

$LOG.level = Logger::INFO

to

$LOG.level = Logger::DEBUG

Then I found out that Frealix was not able to read the memory available of localhost, so I commented out the memory check in FrealixRunner.rb:

line 278:

if (tmp >= @threads_per_job + @num_cores_preserve ) # && tmp_mem > @threads_per_job * @mem_free_per_thread_gb)
@hostname[i] = h
break
end

Now Frealix is working :-)